logo

Could not compile stylesheet for simplistic. Using last compiled stylesheet.

J990 pins state during the boot process

posted in IGEPv2
Tuesday, March 12 2013, 10:36 AM
fparadell
fparadell
Offline
0
I'm working on a project with IGEPv2, it boots from the microSD Linaro operating system.
I have a plaque attached with GPIOs J990 connector using pins 3 through 22.
I'm using 8 input pins and 12 output pins, where I have connected some LEDs and some relays.
The fact is that during the process launched, I see some LEDs light up, and gpio137 gpio157 specifically, and I hear a relay switch.
When he finishes the boot process, all ports are initialized GPIO, and everything works, but I need to avoid problems during the boot process.

How I can get during the boot process I leave all connector pins to 0?
Do I need an MLO file modified to keep all pins to 0?

Regards.

Accepted Answer

Wednesday, March 13 2013, 08:46 AM - #permalink
0
Hi fparadell,

Yes, at least you should create a custom MLO. You should download the source code and add mux configurations to the code.

You can download the source code from out git repositories:

http://git.isee.biz/?p=pub/scm/igep-x-l ... ;a=summary

Hope it helps you.
The reply is currently minimized Show
Responses (0)
  • There are no replies here yet.
Your Reply

SUPPORT


This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.
IGEP Community Wiki
IGEP Community Forum
IGEP Community Online Chat