logo

Could not compile stylesheet for simplistic. Using last compiled stylesheet.
0
Hi,

I'm trying to make/install igep-dsp-gst-framework-3_40_00.tar.bz2 on SDK VM for COM MODULE RE6

This thread has been very useful for some early troubles: http://forum.isee.biz/viewtopic.php?f=80&t=7208

When I upgrade the kernel on microsd card (README step 4.3.1) and then reboot, I get LED near USB connector green, but LED far away from USB connector is red.

Can you offer any suggestions on how to diagnose the problem?

Here are small things I noticed during install:

	Shebang for install_toolchain.sh calls for /bin/sh, but "read -n1 .." fails under sh (needs bash)
	I did not perform toolchain install, though, since SDK VM 20120725 already has firmware yocto 1.2.1-2

	Shebang for build_configure.sh has no "!", so it get correctly run as bash (it would fail because of "read -n1 .." under sh)

	Step 4.3.1 reads:
		:> cp target/kernel/kernel_modules/lib / -a
	but I think it needs to be?:
		:> cp target/dm3730-binaries/kernel/kernel_modules/lib / -a

Any help would be appreciated.
Thanks,
Andrew

Complete install steps:
On VM as jdoe:

sudo apt-get install rpm2cpio
sudo apt-get -f install
sudo apt-get install rpm2cpio
rpm2cpio alsa-dev-1.0.25-r1.armv7a.rpm > alsa.cpio
cpio -idm < alsa.cpio
sudo cp -r usr/ /opt/poky/1.2.1/sysroots/armv7a-vfp-neon-poky-linux-gnueabi/

tar -xvjf igep-dsp-gst-framework-3_40_00.tar.bz2
mkdir Projects
mkdir Projects/myigep
mkdir Projects/myigep/workspace
mkdir Projects/myigep/workspace/igep-dsp-gst-framework
mv igep-dsp-gst-framework-3_40_00 Projects/myigep/workspace/igep-dsp-gst-framework
cd Projects/myigep/workspace/igep-dsp-gst-framework/igep-dsp-gst-framework-3_40_00/

sudo apt-get update
sudo apt-get install autoconf
sudo apt-get install libtool

edited Rules.make
PLATFORM=dm3730
WORKSPACE=/home/jdoe/Projects/myigep/workspace/igep-dsp-gst-framework/igep-dsp-gst-framework-3_40_00

./build_configure.sh

Booted IGEP to microSD

On VM
scp -r target root@192.168.7.1:/home/root
ssh root@192.168.7.1

df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 7.2G 1.9G 4.9G 28% /
tmpfs 40.0K 0 40.0K 0% /mnt/.psplash
none 190.0M 148.0K 189.9M 0% /dev
/dev/mmcblk0p2 7.2G 1.9G 4.9G 28% /media/mmcblk0p2
/dev/mmcblk0p1 69.5M 3.1M 66.4M 4% /media/mmcblk0p1
tmpfs 190.0M 104.0K 189.9M 0% /var/volatile
tmpfs 190.0M 0 190.0M 0% /media/ram
/dev/mmcblk0p1 69.5M 3.1M 66.4M 4% /boot

cp target/scripts/igep.ini /boot
cp target/dm3730-binaries/kernel/zImage /boot
sync
cp target/dm3730-binaries/kernel/kernel_modules/lib / -a
depmod -a
cp target/dm3730-binaries/gstreamer-0.10/libgstticodecplugin.so /usr/lib/gstreamer-0.10
cd target/
cd scripts/
cp ../dm3730-binaries/codecs-server/cs.x64P .
exit
reboot board

Accepted Answer

mcaro
mcaro
Offline
Thursday, January 10 2013, 09:38 AM - #permalink
0
QEMU can not emulate the DSP or the IGEPv2 Expansion Board due it don't have the support for it, if you want get the serial console log you should connect the serial cable to the debug UART and using any terminal program capture it ...

http://labs.isee.biz/index.php/Using_se ... ommunicate

Your issue appears related to x-loader and the kernel, please verify that you're using latest x-loader (http://git.isee.biz/?p=pub/scm/igep-x-l ... ;a=summary), maybe you can post here the igep.ini config file that you're using for boot ...

Manel
The reply is currently minimized Show
Responses (8)
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Wednesday, January 09 2013, 01:04 PM - #permalink
    0
    When I upgrade the kernel on microsd card (README step 4.3.1) and then reboot, I get LED near USB connector green, but LED far away from USB connector is red. Can you offer any suggestions on how to diagnose the problem?
    Do you've the serial console log ? Manel
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 09 2013, 04:16 PM - #permalink
    0
    Thank you for the response. Can you tell me how to collect a console log during boot of COM MODULE?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 09 2013, 04:30 PM - #permalink
    0
    Hi,

    Perhaps the following is useful information to help identify problem?

    I try to install framework on QEMU. See boot messages below .. I don't know how to interpret messages well (eg. I don't know if it should say IGEP0020 when I have IGEP0030, I don't know if "MCP251x didn't enter in conf mode..." is bad). QEMU seem to boot enough to give me a command line.

    Here are my steps. Note that I change README command:

    cp target/kernel/kernel_modules/lib / -a

    to be

    cp -a target/kernel/kernel_modules/lib /

    (I don't think -a should be at end? But I may be mistaken)

    STEPS:

    tar -xvjf QEMU-linaro.2012.12.01.tar.bz2

    cd QEMU/

    tar -xvzf qemu-linaro.tar.gz

    tar -xvzf igep-nano.img.tgz

    sudo mount -o loop,offset=$[63*512] igep-nano.img /mnt

    sudo cp ~jdoe/Projects/myigep/workspace/igep-dsp-gst-framework/igep-dsp-gst-framework-3_40_00/target/scripts/igep.ini /mnt

    sudo cp ~jdoe/Projects/myigep/workspace/igep-dsp-gst-framework/igep-dsp-gst-framework-3_40_00/target/dm3730-binaries/kernel/zImage /mnt

    sudo umount /mnt

    sudo mount -o loop,offset=$[106496*512] igep-nano.img /mnt

    sudo cp -a ~jdoe/Projects/myigep/workspace/igep-dsp-gst-framework/igep-dsp-gst-framework-3_40_00/target/dm3730-binaries/kernel/kernel_modules/lib /mnt

    sudo umount /mnt



    qemu-linaro/bin/qemu-system-arm -M igep -m 512 -clock unix -serial stdio -drive file=igep-nano.img,if=sd,cache=writeback -usb -monitor telnet:localhost:7100,server,nowait,nodelay -device usb-kbd -device usb-mouse

    VNC server running on `127.0.0.1:5900'

    IGEP-X-Loader 2.3.0-1 (Jan 10 2012 - 13:08:47)
    XLoader: IGEPv2 : kernel boot ...
    Uncompressing Linux... done, booting the kernel.
    [ 0.000000] Linux version 2.6.37 (jdoe@ubuntu) (gcc version 4.6.4 20120303 (prerelease) (GCC) ) #1 Wed Jan 9 06:09:23 EST 2013
    [ 0.000000] CPU: ARMv7 Processor [412fc083] revision 3 (ARMv7), cr=10c53c7f
    [ 0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
    [ 0.000000] Machine: IGEP0020 board
    [ 0.000000] IGEP: IGEP0020 machine + IGEP0022 (buddy)
    [ 0.000000] IGEP: buddy options: modem=yes
    [ 0.000000] Reserving 41943040 bytes SDRAM for VRAM
    [ 0.000000] Memory policy: ECC disabled, Data cache writeback
    [ 0.000000] OMAP3630 ES1.1 (iva sgx neon isp 192mhz_clk )
    [ 0.000000] SRAM: Mapped pa 0x40200000 to va 0xfe400000 size: 0x10000
    [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 99586
    [ 0.000000] Kernel command line: console=ttyO2,115200n8 mem=50M@0x80000000 mem=383M@0x88000000 boot_delay=0 nocompcache=1 omapfb.mode=dvi:hd720-16@50 vram=40M omapfb.vram=0:12M,1:16M,2:12M smsc911x.mac0=0xb2,0xb0,0x15,0xb5,0xcd,0xde smsc911x.mac1=0xb2,0xb0,0x15,0xb5,0xcd,0xdf smsc911x.mac=0xb2,0xb0,0x15,0xb5,0xcd,0xde root=/dev/mmcblk0p2 rw rootwait buddy=igep0022 buddy.modem=yes
    [ 0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
    [ 0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
    [ 0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
    [ 0.000000] Memory: 50MB 342MB 1MB = 393MB total
    [ 0.000000] Memory: 391968k/391968k available, 51424k reserved, 0K highmem
    [ 0.000000] Virtual kernel memory layout:
    [ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
    [ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
    [ 0.000000] DMA : 0xffc00000 - 0xffe00000 ( 2 MB)
    [ 0.000000] vmalloc : 0xe0000000 - 0xf8000000 ( 384 MB)
    [ 0.000000] lowmem : 0xc0000000 - 0xdff00000 ( 511 MB)
    [ 0.000000] modules : 0xbf000000 - 0xc0000000 ( 16 MB)
    [ 0.000000] .init : 0xc0008000 - 0xc003d000 ( 212 kB)
    [ 0.000000] .text : 0xc003d000 - 0xc05d2078 (5717 kB)
    [ 0.000000] .data : 0xc05d4000 - 0xc061fc60 ( 304 kB)
    [ 0.000000] NR_IRQS:409
    [ 0.000000] Clocking rate (Crystal/Core/MPU): 26.0/400/600 MHz
    [ 0.000000] Reprogramming SDRC clock to 400000000 Hz
    [ 0.000000] IRQ: Found an INTC at 0xfa200000 (revision 4.0) with 96 interrupts
    [ 0.000000] Total of 96 interrupts on 1 active controller
    [ 0.000000] GPMC revision 5.0
    [ 0.000000] Trying to install interrupt handler for IRQ402
    [ 0.000000] Trying to install interrupt handler for IRQ403
    [ 0.000000] Trying to install interrupt handler for IRQ404
    [ 0.000000] Trying to install interrupt handler for IRQ405
    [ 0.000000] Trying to install interrupt handler for IRQ406
    [ 0.000000] Trying to install interrupt handler for IRQ407
    [ 0.000000] Trying to install interrupt handler for IRQ408
    [ 0.000000] Trying to install type control for IRQ409
    [ 0.000000] Trying to set irq flags for IRQ409
    [ 0.000000] OMAP clockevent source: GPTIMER1 at 32768 Hz
    [ 0.000000] Console: colour dummy device 80x30
    [ 0.000000] Calibrating delay loop... 401.24 BogoMIPS (lpj=1568768)
    [ 0.000000] pid_max: default: 32768 minimum: 301
    [ 0.000000] Security Framework initialized
    [ 0.000000] Mount-cache hash table entries: 512
    [ 0.000000] CPU: Testing write buffer coherency: ok
    [ 0.000000] regulator: core version 0.5
    [ 0.000000] regulator: dummy:
    [ 0.000000] NET: Registered protocol family 16
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] OMAP GPIO hardware version 2.5
    [ 0.000000] omap_mux_init: Add partition: #1: core, flags: 0
    [ 0.000000] IGEP: Hardware Rev. C
    [ 0.000000] IGEP: initializing OneNAND memory device
    [ 0.000000] hw-breakpoint: found 1 breakpoint and 1 watchpoint registers.
    [ 0.000000] hw-breakpoint: maximum watchpoint size is 4 bytes.
    [ 0.000000] OMAP DMA hardware revision 5.0
    [ 0.052520] bio: create slab at 0
    [ 0.057434] regulator: VDD 3V3: 3300 mV normal
    [ 0.064453] SCSI subsystem initialized
    [ 0.073883] usbcore: registered new interface driver usbfs
    [ 0.074798] usbcore: registered new interface driver hub
    [ 0.075347] usbcore: registered new device driver usb
    [ 0.078613] omap_i2c omap_i2c.1: bus 1 rev4.0 at 2600 kHz
    [ 0.084381] twl4030: PIH (irq 7) chaining IRQs 368..375
    [ 0.084533] twl4030: power (irq 373) chaining IRQs 376..383
    [ 0.085632] twl4030: gpio (irq 368) chaining IRQs 384..401
    [ 0.091796] regulator: VUSB1V5: 1500 mV normal standby
    [ 0.093109] regulator: VUSB1V8: 1800 mV normal standby
    [ 0.094238] regulator: VUSB3V1: 3100 mV normal standby
    [ 0.097106] twl4030_usb twl4030_usb: Initialized TWL4030 USB module
    [ 0.101654] regulator: VIO: 1800 <--> 1850 mV at 1800 mV normal standby
    [ 0.102722] regulator: VMMC1: 1850 <--> 3150 mV at 3000 mV normal standby
    [ 0.103790] regulator: VDAC: 1800 mV normal standby
    [ 0.105102] regulator: VPLL2: 1800 mV normal standby
    [ 0.105957] omap_i2c omap_i2c.3: bus 3 rev4.0 at 100 kHz
    [ 0.107055] omap_i2c omap_i2c.2: bus 2 rev4.0 at 400 kHz
    [ 0.112274] Advanced Linux Sound Architecture Driver Version 1.0.23.
    [ 0.117340] cfg80211: Calling CRDA to update world regulatory domain
    [ 0.120086] Switching to clocksource 32k_counter
    [ 0.163574] musb-hdrc: version 6.0, otg (peripheral+host), debug=0
    [ 0.163940] musb-hdrc musb-hdrc.0: dma type: dma-inventra
    [ 0.165527] musb-hdrc musb-hdrc.0: USB OTG mode controller at fa0ab000 using DMA, IRQ 92
    [ 0.168640] NET: Registered protocol family 2
    [ 0.170043] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
    [ 0.173522] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
    [ 0.174041] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
    [ 0.174774] TCP: Hash tables configured (established 16384 bind 16384)
    [ 0.174865] TCP reno registered
    [ 0.174926] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [ 0.175170] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [ 0.176483] NET: Registered protocol family 1
    [ 0.178588] RPC: Registered udp transport module.
    [ 0.178588] RPC: Registered tcp transport module.
    [ 0.178588] RPC: Registered tcp NFSv4.1 backchannel transport module.
    [ 0.186004] omap-iommu omap-iommu.0: isp registered
    [ 0.195404] VFS: Disk quotas dquot_6.5.2
    [ 0.195983] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
    [ 0.208038] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [ 0.212615] JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
    [ 0.218994] msgmni has been set to 765
    [ 0.223663] io scheduler noop registered (default)
    [ 0.223724] io scheduler deadline registered
    [ 0.224975] io scheduler cfq registered
    [ 0.287628] OMAP DSS rev 2.0
    [ 0.308135] OMAP RFBI rev 1.0
    [ 0.308898] OMAP DISPC rev 3.0
    [ 0.309051] OMAP VENC rev 2
    [ 0.309661] omapdss supply vdds_sdi not found, using dummy regulator
    [ 0.309997] OMAP DSI rev 1.0
    [ 0.639739] [drm] Initialized drm 1.1.0 20060810
    [ 0.640411] omap_uart.0: ttyO0 at MMIO 0x4806a000 (irq = 72) is a OMAP UART0
    [ 0.641357] omap_uart.1: ttyO1 at MMIO 0x4806c000 (irq = 73) is a OMAP UART1
    [ 0.642120] omap_uart.2: ttyO2 at MMIO 0x49020000 (irq = 74) is a OMAP UART2
    [ 0.713134] console [ttyO2] enabled
    [ 0.714324] omap_uart.3: ttyO3 at MMIO 0x49042000 (irq = 80) is a OMAP UART3
    [ 0.739685] brd: module loaded
    [ 0.751007] loop: module loaded
    [ 0.751525] at24 2-0050: 128 byte 24c01 EEPROM (writable)
    [ 0.761810] mtdoops: mtd device (mtddev=name/number) must be supplied
    [ 0.762359] omap2-nand driver initializing
    [ 0.763061] OneNAND driver initializing
    [ 0.765075] omap2-onenand omap2-onenand: initializing on CS0, phys base 0x20000000, virtual base e0080000
    [ 0.765960] Muxed OneNAND 256MB 1.8V 16-bit (0x40)
    [ 0.766265] OneNAND version = 0x0121
    [ 0.767822] Scanning device for bad blocks
    [ 0.783721] Creating 3 MTD partitions on "omap2-onenand":
    [ 0.784973] 0x000000000000-0x000000080000 : "X-Loader"
    [ 0.789764] 0x000000080000-0x000000c80000 : "Boot"
    [ 0.792602] 0x000000c80000-0x000010000000 : "File System"
    [ 0.805297] smsc911x: Driver version 2008-10-21.
    [ 0.814849] smsc911x-mdio: probed
    [ 0.816711] eth0: attached PHY driver [SMSC LAN911x Internal PHY] (mii_bus:phy_addr=0:01, irq=-1)
    [ 0.822021] net eth0: MAC Address: 52:54:00:12:34:56
    [ 0.828125] usbcore: registered new interface driver asix
    [ 0.830078] usbcore: registered new interface driver cdc_ether
    [ 0.832275] usbcore: registered new interface driver net1080
    [ 0.834106] usbcore: registered new interface driver cdc_subset
    [ 0.836639] usbcore: registered new interface driver zaurus
    [ 0.839782] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [ 1.847991] ehci-omap ehci-omap.0: OMAP-EHCI Host Controller
    [ 1.850006] ehci-omap ehci-omap.0: new USB bus registered, assigned bus number 1
    [ 1.853576] ehci-omap ehci-omap.0: irq 77, io mem 0x48064800
    [ 1.872009] ehci-omap ehci-omap.0: USB 2.0 started, EHCI 0.00
    [ 1.875366] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    [ 1.881164] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [ 1.882812] usb usb1: Product: OMAP-EHCI Host Controller
    [ 1.883941] usb usb1: Manufacturer: Linux 2.6.37 ehci_hcd
    [ 1.885284] usb usb1: SerialNumber: ehci-omap.0
    [ 1.889678] hub 1-0:1.0: USB hub found
    [ 1.891357] hub 1-0:1.0: 0 ports detected
    [ 1.895294] Initializing USB Mass Storage driver...
    [ 1.898437] usbcore: registered new interface driver usb-storage
    [ 1.900268] USB Mass Storage support registered.
    [ 1.901794] usbcore: registered new interface driver libusual
    [ 1.904541] usbcore: registered new interface driver usbtest
    [ 1.906188] g_ether gadget: using random self ethernet address
    [ 1.911346] g_ether gadget: using random host ethernet address
    [ 1.914733] usb0: MAC 6e:7e:6f:dd:ad:c3
    [ 1.915588] usb0: HOST MAC 62:82:d4:f6:ca:c6
    [ 1.918365] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
    [ 1.919952] g_ether gadget: g_ether ready
    [ 1.920867] musb-hdrc musb-hdrc.0: MUSB HDRC host driver
    [ 1.922027] musb-hdrc musb-hdrc.0: new USB bus registered, assigned bus number 2
    [ 1.925354] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
    [ 1.927246] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [ 1.928924] usb usb2: Product: MUSB HDRC host driver
    [ 1.930206] usb usb2: Manufacturer: Linux 2.6.37 musb-hcd
    [ 1.931976] usb usb2: SerialNumber: musb-hdrc.0
    [ 1.936553] hub 2-0:1.0: USB hub found
    [ 1.941497] hub 2-0:1.0: 1 port detected
    [ 1.944732] mice: PS/2 mouse device common for all mice
    [ 1.950012] input: TWL4030 Keypad as /devices/platform/omap/omap_i2c.1/i2c-1/1-004a/twl4030_keypad/input/input0
    [ 1.957397] input: twl4030_pwrbutton as /devices/platform/omap/omap_i2c.1/i2c-1/1-0049/twl4030_pwrbutton/input/input1
    [ 1.962677] twl_rtc twl_rtc: rtc core: registered twl_rtc as rtc0
    [ 1.964141] twl_rtc twl_rtc: Power up reset detected.
    [ 1.965728] twl_rtc twl_rtc: Enabling TWL-RTC.
    [ 1.971710] i2c /dev entries driver
    [ 1.974670] Linux media interface: v0.10
    [ 1.975952] Linux video capture interface: v2.00
    [ 1.977691] usbcore: registered new interface driver uvcvideo
    [ 1.978881] USB Video Class driver (v1.0.0)
    [ 1.982025] cpuidle: using governor ladder
    [ 1.983581] cpuidle: using governor menu
    [ 1.987976] mmci-omap-hs.0 supply vmmc_aux not found, using dummy regulator
    [ 1.993011] mmci-omap-hs.1 supply vmmc_aux not found, using dummy regulator
    [ 2.006378] omap_sham_mod_init: loading omap-sham driver
    [ 2.007507] omap_sham_mod_init: Unsupported cpu
    [ 2.008453] omap_aes_mod_init: loading omap-aes driver
    [ 2.009521] omap_aes_mod_init: Unsupported cpu
    [ 2.012359] usbcore: registered new interface driver usbhid
    [ 2.013732] usbhid: USB HID core driver
    [ 2.024139] IGEP SoC init
    [ 2.262786] asoc: twl4030-hifi <-> omap-mcbsp-dai.1 mapping ok
    [ 2.278045] ALSA device list:
    [ 2.279113] #0: igep
    [ 2.280944] TCP cubic registered
    [ 2.281677] Initializing XFRM netlink socket
    [ 2.282653] NET: Registered protocol family 17
    [ 2.283874] NET: Registered protocol family 15
    [ 2.287200] L2TP core driver, V2.0
    [ 2.288360] lib80211: common routines for IEEE802.11 drivers
    [ 2.293365] Registering the dns_resolver key type
    [ 2.295562] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 2
    [ 2.314697] ThumbEE CPU extension supported.
    [ 2.339935] mmc0: host does not support reading read-only switch. assuming write-enable.
    [ 2.342071] mmc0: new SD card at address 4567
    [ 2.345458] Power Management for TI OMAP3.
    [ 2.349182] omap_init_power_states: core off state C7 disabled due to i583
    [ 2.359710] mmcblk0: mmc0:4567 QEMU! 512 MiB
    [ 2.373809] smartreflex smartreflex.0: omap_sr_probe: SmartReflex driver initialized
    [ 2.376281] smartreflex smartreflex.1: omap_sr_probe: SmartReflex driver initialized
    [ 2.379943] mmcblk0: p1 p2
    [ 2.389251] SmartReflex Class3 initialized
    [ 2.390411] clock: disabling unused clocks to save power
    [ 2.763519] Console: switching to colour frame buffer device 160x45
    [ 2.792144] twl_rtc twl_rtc: setting system clock to 2013-01-09 11:53:02 UTC (1357732382)
    [ 2.794067] omap_vout omap_vout: probed for an unknown device
    [ 2.811157] EXT3-fs (mmcblk0p2): error: couldn't mount because of unsupported optional features (240)
    [ 2.814086] EXT2-fs (mmcblk0p2): error: couldn't mount because of unsupported optional features (240)
    [ 2.845581] EXT4-fs (mmcblk0p2): warning: checktime reached, running e2fsck is recommended
    [ 2.852905] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
    [ 2.855895] VFS: Mounted root (ext4 filesystem) on device 179:2.
    [ 2.857666] Freeing init memory: 212K
    [ 83.997772] mcp251x spi1.0: MCP251x didn't enter in conf mode after reset
    [ 84.212829] mcp251x spi1.0: probe failed

    Last login: Wed Jan 11 11:37:23 UTC 2012 on tty1
    Welcome to Linaro 11.10 (development branch) (GNU/Linux 2.6.37 armv7l)

    * Documentation: https://wiki.linaro.org/
    root@linaro-nano:~#
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 10 2013, 10:06 AM - #permalink
    0
    Thank you for response.

    Below I show contents of target/scripts/igep.ini.

    Also, you mention x-loader .. I notice in target/ directory:
    igep-x-loader/
    MLO
    x-load.bin
    x-load.bin.ift

    .. but I don't do anything with these files because they are not mentioned in README (I am very novice to kernels, x-loaders, etc). Could this be the problem? Should I do something with these files like with dm3730-binaries/* files and copy them onto COM MODULE?


    [kernel]
    ; Kernel load address, NOT Modify
    kaddress=0x80008000
    ; RAM disk load Address, NOT Modify
    ;rdaddress=0x81600000
    ; Board Serial ID
    serial.low=00000001
    serial.high=00000000
    ; Board Revision
    revision=0003
    ; Kernel Image Name
    kImageName=zImage
    ;kImageName=u-boot.bin
    ; Kernel RAM Disk Image Name
    ;kRdImageName=initrd.img-2.6.35-1010-linaro-omap
    ;kRdImageName=rd-igepv2.bin
    ; Module = 2717 IGEPv2 = 2344
    MachineID=2344
    ; Mode = uboot or kernel
    Mode=kernel

    [kparams]
    ;buddy=mis0010
    ; Setup the Kernel console params
    console=ttyO2,115200n8
    ;console=ttyS2,115200n8
    ; Enable early printk
    ;earlyprintk=serial,tty02,115200
    ;earlyprintk=serial,ttyS2,115200
    ; Setup the Board Memory Configuration
    ;mem=430M
    ;mem=512M
    ;mem=64M
    ;mem=128M
    mem=50M@0x80000000
    mem=383M@0x88000000
    ; Setup the Boot Delay
    boot_delay=0
    ; Setup the ARM Processor Speed
    ; mpurate=1000
    ; Setup the loglevel
    ;loglevel=7
    ; Enable Kernel Debug Output
    ;debug=1
    ; Fix RTC Variable
    ;fixrtc=1
    ; Configure nocompcache variable
    nocompcache=1
    ; Configure Frame Buffer Configuration
    ;omapfb.mode=dvi:1280x720MR-16@60
    omapfb.mode=dvi:hd720-16@50
    ; Configure Video Ram assigned
    vram=40M
    ;vram=4M
    ; Configure Video RAM assigned to every frame buffer
    omapfb.vram=0:12M,1:16M,2:12M
    ; Configure frame buffer debug output
    ;omapfb.debug=1
    ; Configure DSS Video Debug option
    ;omapdss.debug=1
    ; Configure the Board Ethernet Mac Address
    smsc911x.mac0=0xb2,0xb0,0x15,0xb5,0xcd,0xde
    smsc911x.mac1=0xb2,0xb0,0x15,0xb5,0xcd,0xdf
    smsc911x.mac=0xb2,0xb0,0x15,0xb5,0xcd,0xde
    ; --- Configure UBI FS boot ---
    ;ubi.mtd=2
    ;root=ubi0:igep0020-rootfs
    ;rootfstype=ubifs
    ; --- Configure NFS boot ---
    ;ip=192.168.2.123:192.168.2.110:192.168.2.1:255.255.255.0::eth0:
    ;root=/dev/nfs
    ;nfsroot=192.168.2.110:/srv/nfs/linaro_netbook
    ; --- Configure MMC boot ---
    root=/dev/mmcblk0p2 rw rootwait
    ;root=/dev/ram0 rw
    ; Assign Init program
    ;init=/bin/bash
    ;init=/linuxrc
    ; IGEP configuration set
    ;buddy=base0010
    buddy=igep0022
    buddy.modem=yes
    ;musb_hdrc.debug=8
    ;musb_hdrc.use_dma=0
    ;libertas.libertas_debug=1
    The reply is currently minimized Show
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Thursday, January 10 2013, 12:59 PM - #permalink
    0
    I ask about the content of your microsd card ... boot partition ... Manel
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 10 2013, 03:30 PM - #permalink
    0
    Hi, Since I copied target/scripts/igep.ini to microsd /boot, /boot/igep.ini is the same as what I posted. I've confirmed they are the same with diff. Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 10 2013, 04:43 PM - #permalink
    0
    Hi,
    I'm not sure what I'm doing at this point, but I compared my COM MODULE's flash igep.ini with the target(microsd) igep.ini and made the following changes to the microsd's igep.ini:

    serial.low=00000001
    changed to:
    serial.low=00000000

    revision=0003
    changed to:
    revision=0000

    MachineID=2344
    changed to:
    MachineID=2717

    buddy=igep022
    buddy.modem=yes
    changed to:
    buddy=base0010

    I also copied target/igep-x-loader/MLO to microsd boot/

    Now the COM MODULE boots with two green LEDs! I have not yet had a chance to try functionality. I don't know which changes I made were important. I don't know if I should make more changes.

    Can you advise me how to understand this?

    Thank you. Andrew
    The reply is currently minimized Show
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Wednesday, January 16 2013, 09:03 AM - #permalink
    0
    If the two leds be on then the board boot ok ... Manel
    The reply is currently minimized Show
Your Reply

SUPPORT


This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.
IGEP Community Wiki
IGEP Community Forum
IGEP Community Online Chat